SilverStripe comments module includes version of jQuery vulnerable to Cross-site Scripting
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
The silverstripe/comments module, the cwp/starter-theme and the cwp/watea-theme include an outdated version of jQuery by default, which contains XSS vulnerabilities if user input is used in certain contexts. Though no known exploit has been found for these in the existing usage, user customisation to these themes could have made them exploitable. CWP 2.0.0 has been released with the fixed cwp/stater-theme and silverstripe/comments module, and SilverStripe 4.2.0 will be released with the fixed silverstripe-themes/simple theme.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | silverstripe/comments (Packagist) | 1.3.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-frm9-7pm9-5rgc |
- silverstripe/comments (Packagist) Vendor— Affected 1.3.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-frm9-7pm9-5rgc
Remediation
- Fix · GHSA-frm9-7pm9-5rgc silverstripe/comments (Packagist) Fixed in 3.1.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-frm9-7pm9-5rgc
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences