Read the docs
TI-2024-38787 Aliases GHSA-ppm4-r2vc-pg74

SimpleSAMLphp Information Disclosure vulnerability

Priority LOW 38CWE-862Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-862.

Summary

### Background SimpleSAMLphp 1.17 includes a preview of the new user interface to be included in the future version 2.0. This new user interface can be enabled by setting the usenewui configuration option to true, and it includes a new admin interface in a module called admin, which can be disabled. ### Description The new admin interface includes a way to view information about the host where SimpleSAMLphp is installed, by means of the phpinfo() PHP function. An endpoint that exposes the output of that function is included in the admin module for easier debugging. The aforementioned endpoint had no checks for administrator privileges. This would allow any individual to access the given endpoint without authenticating, gathering information about the affected system. ### Affected versions All SimpleSAMLphp 1.17 versions up to 1.17.7 are affected, provided that the new, experimental use interface is enabled, together with the new admin module. ### Impact An attacker could leverage this issue by accessing the unprotected endpoint and gather intelligence about the host where SimpleSAMLphp is deployed, using it later for their own advantage in case other issues arise. However, the impact of this issue is deemed as low, given that the new user interface must be explicitly enabled by means of the usenewui configuration option, and the new admin module must also be enabled. ### Resolution Upgrade to SimpleSAMLphp 1.17.8 or 1.18. This can be done by downloading the package, or by running composer update. Refer to the documentation for instructions on how to run composer. Alternatively, the issue can be mitigated by either disabling the new user interface by setting the usenewui configuration option to false, or by disabling the admin module in the configuration: ``` 'module.enable' => [ ... 'admin' => false, ... ], ```

Why it matters now

Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.17.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—simplesamlphp/simplesamlphp (Packagist)1.17.0 to before 1.17.81.17.8Patch availableGHSA-ppm4-r2vc-pg74
  • simplesamlphp/simplesamlphp (Packagist) Vendor— Affected 1.17.0 to before 1.17.8 Fixed in 1.17.8 Patch available GHSA-ppm4-r2vc-pg74

Remediation

  • Fix · GHSA-ppm4-r2vc-pg74 simplesamlphp/simplesamlphp (Packagist) Fixed in 1.17.8 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-ppm4-r2vc-pg74

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences