Read the docs
TI-2024-38804 Aliases GHSA-vq4j-qcx7-ppc6

Thelia Cross-site Scripting vulnerability in BackOffice

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

The BackOffice of Thelia (`error.html` template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.

Why it matters now

Fix Fixed thelia/thelia (Packagist): 2.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—thelia/thelia (Packagist)2.1.0 to before 2.1.22.1.2Patch availableGHSA-vq4j-qcx7-ppc6
  • thelia/thelia (Packagist) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-vq4j-qcx7-ppc6

Remediation

  • Fix · GHSA-vq4j-qcx7-ppc6 thelia/thelia (Packagist) Fixed in 2.1.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-vq4j-qcx7-ppc6

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences