Thelia authentication bypass vulnerability
Priority LOW 38CWE-287Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-287.
Summary
An authentication bypass was identifed in thelia/thelia project for customer and admin. This vulnerability is present from version 2.0.0-beta1 and is fixed in 2.1.3 and 2.2.0-alpha1.
Why it matters now
Fix Fixed thelia/thelia (Packagist): 2.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | thelia/thelia (Packagist) | 2.0.0-beta1 to before 2.1.3 | 2.1.3 | Patch available | GHSA-g8pg-33v4-9r96 |
- thelia/thelia (Packagist) Vendor— Affected 2.0.0-beta1 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-g8pg-33v4-9r96
Remediation
- Fix · GHSA-g8pg-33v4-9r96 thelia/thelia (Packagist) Fixed in 2.1.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-g8pg-33v4-9r96
References
Other 6
- https://github.com/github/advisory-database/pull/8012
- https://github.com/thelia/thelia/commit/028cfcf507cd8685772e156ec0c860034d407094
- https://github.com/thelia/thelia/commit/71c1cee66d8f2e515e82478f792879fa63843644
- https://github.com/FriendsOfPHP/security-advisories/blob/master/thelia/thelia/2015-04-13-1.yaml
- https://github.com/thelia/thelia
- https://web.archive.org/web/20160502224630/http://thelia.net/version-2-1-3-with-security-fix
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences