Read the docs
TI-2024-38853 Aliases GHSA-vgm8-r9gm-fw59

TYPO3 Cross-Site Scripting in legacy form component

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Failing to sanitize content from editors, the legacy form component is susceptible to Cross-Site Scripting. A valid editor account with access to a form content element is required to exploit this vulnerability.

Why it matters now

Fix Fixed typo3/cms (Packagist): 6.2.18

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—typo3/cms (Packagist)6.2.0 to before 6.2.186.2.18Patch availableGHSA-vgm8-r9gm-fw59
  • typo3/cms (Packagist) Vendor— Affected 6.2.0 to before 6.2.18 Fixed in 6.2.18 Patch available GHSA-vgm8-r9gm-fw59

Remediation

  • Fix · GHSA-vgm8-r9gm-fw59 typo3/cms (Packagist) Fixed in 6.2.18 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-vgm8-r9gm-fw59

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences