Read the docs
TI-2024-38861 Aliases GHSA-4m3g-6r7g-jv4f

Arbitrary JavaScript execution due to using outdated libraries

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

### Summary gradio-pdf projects with dependencies on the pdf.js library are vulnerable to CVE-2024-4367, which allows arbitrary JavaScript execution. ### PoC 1. Generate a pdf file with a malicious script in the fontmatrix. (This will run `alert(‘XSS’)`.) [poc.pdf](https://github.com/user-attachments/files/15516798/poc.pdf) 2. Run the app. In this PoC, I've used the demo for a simple proof. ![1](https://github.com/freddyaboulton/gradio-pdf/assets/114328108/d1bb7626-3d0f-4984-8873-297658d6e77e) 3. Upload a PDF file containing the script. ![2](https://github.com/freddyaboulton/gradio-pdf/assets/114328108/803d8080-c946-446e-bb34-cf5640e1b4de) 4. Check that the script is running. ![3](https://github.com/freddyaboulton/gradio-pdf/assets/114328108/4956b95f-acca-4bb1-a3c2-7dfc96adf890) ### Impact Malicious scripts can be injected into the code, and when linked with vulnerabilities such as CSRF, it can cause even greater damage. In particular, It can become a source of further attacks, especially when linked to social engineering. ### Mitigation Upgrade the pdf.js to v4.2.67, which removes the vulnerability. (or set the option `isEvalSupported` to `false`.) ### Reference 1. https://codeanlabs.com/blog/research/cve-2024-4367-arbitrary-js-execution-in-pdf-js/ 2. https://github.com/mozilla/pdf.js/pull/18015

Why it matters now

Fix Fixed gradio_pdf (PyPI): 0.0.10

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—gradio_pdf (PyPI)before 0.0.100.0.10Patch availableGHSA-4m3g-6r7g-jv4f
  • gradio_pdf (PyPI) Vendor— Affected before 0.0.10 Fixed in 0.0.10 Patch available GHSA-4m3g-6r7g-jv4f

Remediation

  • Fix · GHSA-4m3g-6r7g-jv4f gradio_pdf (PyPI) Fixed in 0.0.10 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-4m3g-6r7g-jv4f

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences