Cross-Site Scripting (XSS) in TYPO3 Backend
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
Failing to properly encode user input, the page module is vulnerable to Cross-Site Scripting. A valid backend user account with permissions to edit plugins is needed to exploit this vulnerability.
Why it matters now
Fix Fixed typo3/cms (Packagist): 6.2.27, 7.6.11, 8.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | typo3/cms (Packagist) | 6.2.0 to before 6.2.27 | 6.2.27 | Patch available | GHSA-hq37-rfjc-mr8h |
| — | typo3/cms (Packagist) | 7.6.0 to before 7.6.11 | 7.6.11 | Patch available | GHSA-hq37-rfjc-mr8h |
| — | typo3/cms (Packagist) | 8.0.0 to before 8.3.1 | 8.3.1 | Patch available | GHSA-hq37-rfjc-mr8h |
- typo3/cms (Packagist) Vendor— Affected 6.2.0 to before 6.2.27 Fixed in 6.2.27 Patch available GHSA-hq37-rfjc-mr8h
- typo3/cms (Packagist) Vendor— Affected 7.6.0 to before 7.6.11 Fixed in 7.6.11 Patch available GHSA-hq37-rfjc-mr8h
- typo3/cms (Packagist) Vendor— Affected 8.0.0 to before 8.3.1 Fixed in 8.3.1 Patch available GHSA-hq37-rfjc-mr8h
Remediation
- Fix · GHSA-hq37-rfjc-mr8h typo3/cms (Packagist) Fixed in 6.2.27 Advisory →
- Fix · GHSA-hq37-rfjc-mr8h typo3/cms (Packagist) Fixed in 7.6.11 Advisory →
- Fix · GHSA-hq37-rfjc-mr8h typo3/cms (Packagist) Fixed in 8.3.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-hq37-rfjc-mr8h
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences