Read the docs
TI-2024-38895 Aliases GHSA-4542-p56h-8xww

Cross-Site Scripting (XSS) vulnerabilities in Neos

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

It has been discovered that Neos is vulnerable to several XSS attacks. Through these vulnerabilities, an attacker could tamper with page rendering, redirect victims to a fake login page, or capture user credentials (such as cookies). With the potential backdoor upload an attacker could gain access to the server itself, to an extent mainly limited by the server setup.

Why it matters now

Fix Fixed typo3/neos (Packagist): 1.2.13, 2.0.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—typo3/neos (Packagist)1.2.0 to before 1.2.131.2.13Patch availableGHSA-4542-p56h-8xww
—typo3/neos (Packagist)2.0.0 to before 2.0.42.0.4Patch availableGHSA-4542-p56h-8xww
  • typo3/neos (Packagist) Vendor— Affected 1.2.0 to before 1.2.13 Fixed in 1.2.13 Patch available GHSA-4542-p56h-8xww
  • typo3/neos (Packagist) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-4542-p56h-8xww

Remediation

  • Fix · GHSA-4542-p56h-8xww typo3/neos (Packagist) Fixed in 1.2.13 Advisory →
  • Fix · GHSA-4542-p56h-8xww typo3/neos (Packagist) Fixed in 2.0.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-4542-p56h-8xww

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences