typo3 Security fix for Flow Swift Mailer package
Priority LOW 38Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
A remote code execution vulnerability has been found in the Swift Mailer library (swiftmailer/swiftmailer) recently. See this advisory for details. If you are not using the default mail() transport, this particular problem does not affect you. Upgrading is of course still recommended!
Why it matters now
Fix Fixed typo3/swiftmailer (Packagist): 4.1.99, 5.4.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | typo3/swiftmailer (Packagist) | 4.1.0 to before 4.1.99 | 4.1.99 | Patch available | GHSA-xjw3-5r5c-m5ph |
| — | typo3/swiftmailer (Packagist) | 5.4.0 to before 5.4.5 | 5.4.5 | Patch available | GHSA-xjw3-5r5c-m5ph |
- typo3/swiftmailer (Packagist) Vendor— Affected 4.1.0 to before 4.1.99 Fixed in 4.1.99 Patch available GHSA-xjw3-5r5c-m5ph
- typo3/swiftmailer (Packagist) Vendor— Affected 5.4.0 to before 5.4.5 Fixed in 5.4.5 Patch available GHSA-xjw3-5r5c-m5ph
Remediation
- Fix · GHSA-xjw3-5r5c-m5ph typo3/swiftmailer (Packagist) Fixed in 4.1.99 Advisory →
- Fix · GHSA-xjw3-5r5c-m5ph typo3/swiftmailer (Packagist) Fixed in 5.4.5 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-xjw3-5r5c-m5ph
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences