Read the docs
TI-2024-38915 Aliases GHSA-f624-8hfq-5fh3

TYPO3 Information Disclosure of Installed Extensions

Priority LOW 38CWE-200Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Information disclosure
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-200.

Summary

It has been discovered that mechanisms used for configuration of RequireJS package loading are susceptible to information disclosure. This way a potential attack can retrieve additional information about installed system and third party extensions.

Why it matters now

Fix Fixed typo3/cms (Packagist): 8.7.23, 9.5.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—typo3/cms (Packagist)8.0.0 to before 8.7.238.7.23Patch availableGHSA-f624-8hfq-5fh3
—typo3/cms (Packagist)9.0.0 to before 9.5.49.5.4Patch availableGHSA-f624-8hfq-5fh3
  • typo3/cms (Packagist) Vendor— Affected 8.0.0 to before 8.7.23 Fixed in 8.7.23 Patch available GHSA-f624-8hfq-5fh3
  • typo3/cms (Packagist) Vendor— Affected 9.0.0 to before 9.5.4 Fixed in 9.5.4 Patch available GHSA-f624-8hfq-5fh3

Remediation

  • Fix · GHSA-f624-8hfq-5fh3 typo3/cms (Packagist) Fixed in 8.7.23 Advisory →
  • Fix · GHSA-f624-8hfq-5fh3 typo3/cms (Packagist) Fixed in 9.5.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f624-8hfq-5fh3

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences