Read the docs
TI-2024-38934 Aliases GHSA-5gmf-3c43-q73v

ZendFramework vulnerable to Cross-site Scripting

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

`Zend\Debug`, `Zend\Feed\PubSubHubbub`, `Zend\Log\Formatter\Xml`, `Zend\Tag\Cloud\Decorator`, `Zend\Uri`, `Zend\View\Helper\HeadStyle, Zend\View\Helper\Navigation\Sitemap`, and `Zend\View\Helper\Placeholder\Container\AbstractStandalone` were not using `Zend\Escaper` when escaping HTML, HTML attributes, and/or URLs. While most were performing some escaping, because they were not using context-appropriate escaping mechanisms, they could potentially be exploited to perform Cross Site Scripting (XSS) attacks.

Why it matters now

Fix Fixed zendframework/zendframework (Packagist): 2.0.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—zendframework/zendframework (Packagist)2.0.0 to before 2.0.12.0.1Patch availableGHSA-5gmf-3c43-q73v
  • zendframework/zendframework (Packagist) Vendor— Affected 2.0.0 to before 2.0.1 Fixed in 2.0.1 Patch available GHSA-5gmf-3c43-q73v

Remediation

  • Fix · GHSA-5gmf-3c43-q73v zendframework/zendframework (Packagist) Fixed in 2.0.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-5gmf-3c43-q73v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences