Read the docs
TI-2024-38940 Aliases GHSA-qf36-fx9f-232x

ZendFramework potential SQL Injection Vector When Using PDO_MySql

Priority LOW 38CWE-89Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
SQL injection
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-89.

Summary

Developers using non-ASCII-compatible encodings in conjunction with the MySQL PDO driver of PHP may be vulnerable to SQL injection attacks. Developers using ASCII-compatible encodings like UTF8 or latin1 are not affected by this PHP issue, which is described in more detail here: http://bugs.php.net/bug.php?id=47802 The PHP Group included a feature in PHP 5.3.6+ that allows any character set information to be passed as part of the DSN in PDO to allow both the database as well as the C-level driver to be aware of which charset is in use which is of special importance when PDO's quoting mechanisms are utilized, which Zend Framework also relies on.

Why it matters now

Fix Fixed zendframework/zendframework1 (Packagist): 1.10.9, 1.11.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—zendframework/zendframework1 (Packagist)1.10.0 to before 1.10.91.10.9Patch availableGHSA-qf36-fx9f-232x
—zendframework/zendframework1 (Packagist)1.11.0 to before 1.11.61.11.6Patch availableGHSA-qf36-fx9f-232x
  • zendframework/zendframework1 (Packagist) Vendor— Affected 1.10.0 to before 1.10.9 Fixed in 1.10.9 Patch available GHSA-qf36-fx9f-232x
  • zendframework/zendframework1 (Packagist) Vendor— Affected 1.11.0 to before 1.11.6 Fixed in 1.11.6 Patch available GHSA-qf36-fx9f-232x

Remediation

  • Fix · GHSA-qf36-fx9f-232x zendframework/zendframework1 (Packagist) Fixed in 1.10.9 Advisory →
  • Fix · GHSA-qf36-fx9f-232x zendframework/zendframework1 (Packagist) Fixed in 1.11.6 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qf36-fx9f-232x

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences