Read the docs
TI-2024-38945 Aliases GHSA-g52p-86j5-xr8q

ZendFramework Potential Cross-site Scripting in Development Environment Error View Script

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

The default error handling view script generated using `Zend_Tool` failed to escape request parameters when run in the "development" configuration environment, providing a potential XSS attack vector. `Zend_Tool_Project_Context_Zf_ViewScriptFile` was patched such that the view script template now calls the `escape()` method on dumped request variables. Zend Framework 1.11.4 includes a patch that adds escaping to the generated error/error.phtml view script, ensuring that request variables are escaped appropriately for the browser. Do note, however, that this will not update any previously generated code. You will still need to follow the next advice for previously generated error view scripts.

Why it matters now

Fix Fixed zendframework/zendframework1 (Packagist): 1.11.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—zendframework/zendframework1 (Packagist)1.0.0 to before 1.11.41.11.4Patch availableGHSA-g52p-86j5-xr8q
  • zendframework/zendframework1 (Packagist) Vendor— Affected 1.0.0 to before 1.11.4 Fixed in 1.11.4 Patch available GHSA-g52p-86j5-xr8q

Remediation

  • Fix · GHSA-g52p-86j5-xr8q zendframework/zendframework1 (Packagist) Fixed in 1.11.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-g52p-86j5-xr8q

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences