Zendframework potential Cross-site Scripting vector in `Zend_Service_ReCaptcha_MailHide`
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
`Zend_Service_ReCaptcha_MailHide` had a potential XSS vulnerability. Due to the fact that the email address was never validated, and because its use of `htmlentities()` did not include the encoding argument, it was potentially possible for a malicious user aware of the issue to inject a specially crafted multibyte string as an attack via the CAPTCHA's email argument
Why it matters now
Fix Fixed zendframework/zendframework1 (Packagist): 1.7.9, 1.8.5, 1.9.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | zendframework/zendframework1 (Packagist) | 1.7.0 to before 1.7.9 | 1.7.9 | Patch available | GHSA-4v57-pwvf-x35j |
| — | zendframework/zendframework1 (Packagist) | 1.8.0 to before 1.8.5 | 1.8.5 | Patch available | GHSA-4v57-pwvf-x35j |
| — | zendframework/zendframework1 (Packagist) | 1.9.0 to before 1.9.7 | 1.9.7 | Patch available | GHSA-4v57-pwvf-x35j |
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.7.0 to before 1.7.9 Fixed in 1.7.9 Patch available GHSA-4v57-pwvf-x35j
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.8.0 to before 1.8.5 Fixed in 1.8.5 Patch available GHSA-4v57-pwvf-x35j
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.9.0 to before 1.9.7 Fixed in 1.9.7 Patch available GHSA-4v57-pwvf-x35j
Remediation
- Fix · GHSA-4v57-pwvf-x35j zendframework/zendframework1 (Packagist) Fixed in 1.7.9 Advisory →
- Fix · GHSA-4v57-pwvf-x35j zendframework/zendframework1 (Packagist) Fixed in 1.8.5 Advisory →
- Fix · GHSA-4v57-pwvf-x35j zendframework/zendframework1 (Packagist) Fixed in 1.9.7 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-4v57-pwvf-x35j
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences