Read the docs
TI-2024-38960 Aliases GHSA-qg7m-mwxm-j3h7

Zend-developer-tools information disclosure vulnerability

Priority LOW 38CWE-200Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Information disclosure
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-200.

Summary

The package zendframework/zend-developer-tools provides a web-based toolbar for introspecting an application. When updating the package to support PHP 7.3, a change was made that could potentially prevent toolbar entries that are enabled by default from being disabled.

Why it matters now

Fix Fixed zendframework/zend-developer-tools (Packagist): 1.2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—zendframework/zend-developer-tools (Packagist)1.2.2 to before 1.2.31.2.3Patch availableGHSA-qg7m-mwxm-j3h7
  • zendframework/zend-developer-tools (Packagist) Vendor— Affected 1.2.2 to before 1.2.3 Fixed in 1.2.3 Patch available GHSA-qg7m-mwxm-j3h7

Remediation

  • Fix · GHSA-qg7m-mwxm-j3h7 zendframework/zend-developer-tools (Packagist) Fixed in 1.2.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qg7m-mwxm-j3h7

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences