Taipy 3.1.1 affected by CVEs on flask-core and pymongo
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Summary Indirect CVEs affect Taipy 3.1.1 ### Details Taipy 3.1.1 is affected by two existing CVEs: CVE-2024-1681 affects flask-core <4.0.1 and taipy 3.1.1 needs <=4.0.0 CVE-2024-5629 affects pymongo <4.6.3 and taipy 3.1.1 needs <=4.6.1 Please see References for further details. ### Patch please upgrade to the following versions: Fixed on patch versions: >=3.1.2 and on major releases: >=4.0.0 ### Impact pre-commit breaks when using dependency Taipy 3.1.1
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | taipy (PyPI) | before 4.0.0 | 4.0.0 | Patch available | GHSA-pp84-v3mw-gg4w |
- taipy (PyPI) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-pp84-v3mw-gg4w
Remediation
- Fix · GHSA-pp84-v3mw-gg4w taipy (PyPI) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-pp84-v3mw-gg4w
References
Advisory 4
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences