Read the docs
TI-2024-39023 Aliases GHSA-qr4w-53vh-m672

opencv-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863

Priority LOW 38CWE-787Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

opencv-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-python v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.

Why it matters now

Fix Fixed opencv-python (PyPI): 4.8.1.78

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—opencv-python (PyPI)before 4.8.1.784.8.1.78Patch availableGHSA-qr4w-53vh-m672
  • opencv-python (PyPI) Vendor— Affected before 4.8.1.78 Fixed in 4.8.1.78 Patch available GHSA-qr4w-53vh-m672

Remediation

  • Fix · GHSA-qr4w-53vh-m672 opencv-python (PyPI) Fixed in 4.8.1.78 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qr4w-53vh-m672

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences