Pimcore includes vulnerable PHPOffice/PhpSpreadsheet
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Summary Pimcore 10.6.x and Enterprise 10.6.x versions currently depend on PHPOffice/PhpSpreadsheet version 1.x, which has recently been identified with a security vulnerability (CVE-2024-45048). To mitigate this issue, it is recommended to update to the latest version 2.2.2. For more details, please refer to the official advisory: [GHSA-ghg6-32f9-2jp7](https://github.com/advisories/GHSA-ghg6-32f9-2jp7).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pimcore/data-importer (Packagist) | before 1.8.9 | 1.8.9 | Patch available | GHSA-hq76-662x-7mw4 |
| — | pimcore/data-importer (Packagist) | 1.9.0 to before 1.9.3 | 1.9.3 | Patch available | GHSA-hq76-662x-7mw4 |
| — | pimcore/admin-ui-classic-bundle (Packagist) | before 1.3.11 | 1.3.11 | Patch available | GHSA-hq76-662x-7mw4 |
| — | pimcore/admin-ui-classic-bundle (Packagist) | 1.4.0 to before 1.4.7 | 1.4.7 | Patch available | GHSA-hq76-662x-7mw4 |
| — | pimcore/admin-ui-classic-bundle (Packagist) | 1.5.0 to before 1.5.4 | 1.5.4 | Patch available | GHSA-hq76-662x-7mw4 |
| — | pimcore/pimcore (Packagist) | 10.6.9.0 to before 10.6.9.12 | 10.6.9.12 | Patch available | GHSA-hq76-662x-7mw4 |
| — | pimcore/pimcore (Packagist) | 11.1.0.0 to before 11.1.6.11 | 11.1.6.11 | Patch available | GHSA-hq76-662x-7mw4 |
- pimcore/data-importer (Packagist) Vendor— Affected before 1.8.9 Fixed in 1.8.9 Patch available GHSA-hq76-662x-7mw4
- pimcore/data-importer (Packagist) Vendor— Affected 1.9.0 to before 1.9.3 Fixed in 1.9.3 Patch available GHSA-hq76-662x-7mw4
- pimcore/admin-ui-classic-bundle (Packagist) Vendor— Affected before 1.3.11 Fixed in 1.3.11 Patch available GHSA-hq76-662x-7mw4
- pimcore/admin-ui-classic-bundle (Packagist) Vendor— Affected 1.4.0 to before 1.4.7 Fixed in 1.4.7 Patch available GHSA-hq76-662x-7mw4
- pimcore/admin-ui-classic-bundle (Packagist) Vendor— Affected 1.5.0 to before 1.5.4 Fixed in 1.5.4 Patch available GHSA-hq76-662x-7mw4
- pimcore/pimcore (Packagist) Vendor— Affected 10.6.9.0 to before 10.6.9.12 Fixed in 10.6.9.12 Patch available GHSA-hq76-662x-7mw4
- pimcore/pimcore (Packagist) Vendor— Affected 11.1.0.0 to before 11.1.6.11 Fixed in 11.1.6.11 Patch available GHSA-hq76-662x-7mw4
Remediation
- Fix · GHSA-hq76-662x-7mw4 pimcore/data-importer (Packagist) Fixed in 1.8.9 Advisory →
- Fix · GHSA-hq76-662x-7mw4 pimcore/data-importer (Packagist) Fixed in 1.9.3 Advisory →
- Fix · GHSA-hq76-662x-7mw4 pimcore/admin-ui-classic-bundle (Packagist) Fixed in 1.3.11 Advisory →
- Fix · GHSA-hq76-662x-7mw4 pimcore/admin-ui-classic-bundle (Packagist) Fixed in 1.4.7 Advisory →
- Fix · GHSA-hq76-662x-7mw4 pimcore/admin-ui-classic-bundle (Packagist) Fixed in 1.5.4 Advisory →
- Fix · GHSA-hq76-662x-7mw4 pimcore/pimcore (Packagist) Fixed in 10.6.9.12 Advisory →
- Fix · GHSA-hq76-662x-7mw4 pimcore/pimcore (Packagist) Fixed in 11.1.6.11 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-hq76-662x-7mw4
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences