pyca/cryptography has a vulnerable OpenSSL included in cryptography wheels
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 37.0.0-43.0.0 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20240903.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | cryptography (PyPI) | 37.0.0 to before 43.0.1 | 43.0.1 | Patch available | GHSA-h4gh-qq45-vh27 |
- cryptography (PyPI) Vendor— Affected 37.0.0 to before 43.0.1 Fixed in 43.0.1 Patch available GHSA-h4gh-qq45-vh27
Remediation
- Fix · GHSA-h4gh-qq45-vh27 cryptography (PyPI) Fixed in 43.0.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-h4gh-qq45-vh27
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences