omniauth-saml vulnerable to Improper Verification of Cryptographic Signature
Priority LOW 38CWE-347Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-347.
Summary
ruby-saml, the dependent SAML gem of omniauth-saml has a signature wrapping vulnerability in <= v1.12.0 and v1.13.0 to v1.16.0 , see https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2 As a result, omniauth-saml created a [new release](https://github.com/omniauth/omniauth-saml/releases) by upgrading ruby-saml to the patched versions v1.17.
Why it matters now
Fix Fixed omniauth-saml (RubyGems): 2.1.2, 1.10.5, 2.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | omniauth-saml (RubyGems) | 2.0.0 to before 2.1.2 | 2.1.2 | Patch available | GHSA-cvp8-5r8g-fhvq |
| — | omniauth-saml (RubyGems) | before 1.10.5 | 1.10.5 | Patch available | GHSA-cvp8-5r8g-fhvq |
| — | omniauth-saml (RubyGems) | 2.2.0 to before 2.2.1 | 2.2.1 | Patch available | GHSA-cvp8-5r8g-fhvq |
- omniauth-saml (RubyGems) Vendor— Affected 2.0.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-cvp8-5r8g-fhvq
- omniauth-saml (RubyGems) Vendor— Affected before 1.10.5 Fixed in 1.10.5 Patch available GHSA-cvp8-5r8g-fhvq
- omniauth-saml (RubyGems) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-cvp8-5r8g-fhvq
Remediation
- Fix · GHSA-cvp8-5r8g-fhvq omniauth-saml (RubyGems) Fixed in 2.1.2 Advisory →
- Fix · GHSA-cvp8-5r8g-fhvq omniauth-saml (RubyGems) Fixed in 1.10.5 Advisory →
- Fix · GHSA-cvp8-5r8g-fhvq omniauth-saml (RubyGems) Fixed in 2.2.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-cvp8-5r8g-fhvq
References
Other 6
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2
- https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-cvp8-5r8g-fhvq
- https://github.com/omniauth/omniauth-saml/commit/4274e9d57e65f2dcaae4aa3b2accf831494f2ddd
- https://github.com/omniauth/omniauth-saml/commit/6c681fd082ab3daf271821897a40ab3417382e29
- https://github.com/omniauth/omniauth-saml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/GHSA-cvp8-5r8g-fhvq.yml
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences