Read the docs
TI-2024-39092 Aliases GHSA-4h8f-c635-25p7

ibexa/post-install affected by Breach with Varnish VCL

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact This is not a vulnerability in the code per se, but included platform.sh Varnish VCL templates and Apache/Nginx vhost templates enable compression of API and JSON messages. This is a potential case of the BREACH vulnerability, which affects HTTP compression, where secrets can be extracted through carefully crafted requests. The fix disables compression in these templates. Please make sure to make the same change in your configuration files, see the release notes for specific instructions. ### Patches - See "Patched versions". - v1.0: https://github.com/ibexa/post-install/commit/d91cc02623dd3263a99a94ace133c95e48909e5d - v4.6: https://github.com/ibexa/post-install/commit/ae7c3c2081a862c75b90828f08bd74436ceb8fe8 ### Workarounds Make sure HTTP compression is disabled for REST API requests and other communication that might contain secrets. ### References - Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates - Release notes v3.3: https://doc.ibexa.co/en/latest/update_and_migration/from_3.3/update_from_3.3/#v3341 - Release notes v4.6: https://doc.ibexa.co/en/latest/update_and_migration/from_4.6/update_from_4.6/#v4614 - https://github.com/ezsystems/ezplatform-http-cache/security/advisories/GHSA-mgfg-7533-7jf6 - https://github.com/ibexa/http-cache/security/advisories/GHSA-fh7v-q458-7vmw - https://www.breachattack.com/

Why it matters now

Fix Fixed ibexa/post-install (Packagist): 1.0.16, 4.6.14

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—ibexa/post-install (Packagist)1.0.0 to before 1.0.161.0.16Patch availableGHSA-4h8f-c635-25p7
—ibexa/post-install (Packagist)4.6.0 to before 4.6.144.6.14Patch availableGHSA-4h8f-c635-25p7
  • ibexa/post-install (Packagist) Vendor— Affected 1.0.0 to before 1.0.16 Fixed in 1.0.16 Patch available GHSA-4h8f-c635-25p7
  • ibexa/post-install (Packagist) Vendor— Affected 4.6.0 to before 4.6.14 Fixed in 4.6.14 Patch available GHSA-4h8f-c635-25p7

Remediation

  • Fix · GHSA-4h8f-c635-25p7 ibexa/post-install (Packagist) Fixed in 1.0.16 Advisory →
  • Fix · GHSA-4h8f-c635-25p7 ibexa/post-install (Packagist) Fixed in 4.6.14 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-4h8f-c635-25p7

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences