Brute force possible due to non-expiring SMS OTPs in WSO2 Identity Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-613.
Summary
WSO2 Identity Server from 5.11.0 before 5.11.0.372, from 6.0.0 before 6.0.0.227, and from 6.1.0 before 6.1.0.219 does not enforce a default expiry time for SMS one-time passwords used in multi-factor authentication. Unused OTPs remain valid indefinitely, so an attacker can keep guessing a code without any time limit (CWE-613). A successful brute force attack can bypass MFA and lead to takeover of a user's account.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The WSO2 Identity Server fails to enforce a default expiry time for SMS One-Time Passwords (OTPs) used in multi-factor authentication (MFA). This allows unused OTPs to remain valid indefinitely, presenting an opportunity for malicious actors to conduct brute force attacks by repeatedly guessing the OTP. The absence of automatic expiration for OTPs grants attackers an unlimited timeframe to attempt guessing the correct code. A successful brute force attack can lead to an MFA bypass, resulting in the unauthorized takeover of a user's account and compromising the security and privacy of both the individual and the system.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 Identity Server | 5.11.0 to before 5.11.0.372; 6.0.0 to before 6.0.0.227; 6.1.0 to before 6.1.0.219 | 5.11.0.372, 6.0.0.227, 6.1.0.219 | Patch available | CNA |
- WSO2 Identity Server VendorWSO2 Affected 5.11.0 to before 5.11.0.372; 6.0.0 to before 6.0.0.227; 6.1.0 to before 6.1.0.219 Fixed in 5.11.0.372, 6.0.0.227, 6.1.0.219 Patch available CNA
Remediation
Upgrade WSO2 Identity Server to 5.11.0.372, 6.0.0.227, or 6.1.0.219 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.11.0.372, 6.0.0.227, 6.1.0.219
Timeline
- 2026-10-08 Threatist record created from CVE-2024-8122
- 2026-10-08 Alias added: GHSA-jj5j-4f68-3g72
- 2026-10-08 CISA SSVC decision points changed
- 2026-10-08 Priority changed: MEDIUM → LOW
References
More WSO2 vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2022-18808 An issue was discovered in WSO2 Enterprise Integrator 6.4.0. CVSS 3.1MEDIUM 6.1
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-04130 WSO2 carbon-registry Advanced Search advancedSearchForm-ajaxprocessor.jsp cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-8122 · CVE Program
- CVE-2024-8122 · NVD
- FIRST EPSS
- GHSA-jj5j-4f68-3g72 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences