Privilege escalation in Frappe via document action
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
Frappe before 14.81.4 and 15.x before 15.41.0 contains an improper privilege management flaw (CWE-269) in a certain document action. It lets an authenticated attacker with Website User access escalate to the System Manager role. Combined with additional steps, the attacker can obtain administrative System Manager privileges in the Frappe application.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Frappe before 14.81.4 and 15.x before 15.41.0 contains an improper privilege management vulnerability involving a certain document action that permits escalation from the Website User role to System Manager. Authenticated attackers with Website User access can combine this document action with additional steps to obtain administrative System Manager privileges in the Frappe application.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Frappe to version 14.81.4 for the 14 branch or to version 15.41.0 for the 15 branch. The sources do not list a vendor advisory for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA frappe (frappe) Fixed in 14.81.4, 15.41.0
Timeline
- 2026-10-12 Threatist record created from CVE-2024-58390
- 2026-10-13 Alias added: GHSA-g6cq-m3m2-c4h3
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-13 CISA SSVC decision points changed
References
More frappe vulnerabilities
- TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
- TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
- TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
- TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
Sources
- CVE-2024-58390 · CVE Program
- CVE-2024-58390 · NVD
- FIRST EPSS
- GHSA-g6cq-m3m2-c4h3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences