Cross-site scripting in Frappe printview via unescaped parameters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Frappe before 14.58.0 and 15.x before 15.4.0 contains a cross-site scripting vulnerability in printview. Printview parameters are not escaped before being rendered (CWE-79). A remote unauthenticated attacker can craft a malicious printview URL that, when a user visits it, injects HTML and executes script in the victim's browser session, with user interaction required.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Frappe before 14.58.0 and 15.x before 15.4.0 contains a cross-site scripting vulnerability in printview because printview parameters are not escaped before being rendered. Remote attackers can craft a malicious printview URL that, when visited by a victim, injects HTML and executes script in the victim's browser session.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade frappe to version 14.58.0 for the 14.x branch or 15.4.0 for the 15.x branch. CISA's catalog does not list this vulnerability.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA frappe (frappe) Fixed in 14.58.0, 15.4.0
Timeline
- 2026-10-12 Threatist record created from CVE-2024-58391
- 2026-10-13 Alias added: GHSA-8v87-5f8f-xgxh
- 2026-10-13 CISA SSVC decision points changed
References
More frappe vulnerabilities
- TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
- TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
- TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
- TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
Sources
- CVE-2024-58391 · CVE Program
- CVE-2024-58391 · NVD
- FIRST EPSS
- GHSA-8v87-5f8f-xgxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences