Rancher project name collision exposes projects in other clusters
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
SUSE Rancher from 2.8.0 before 2.9.9, from 2.10.0 before 2.10.5, and from 2.11.0 before 2.11.1 is affected. Rancher stores each project's related resources in a namespace on the local cluster named after the project, so a user who creates a project with the same name as an existing project in another cluster gains access to that project (CWE-863). A user with low privileges who can create projects on one cluster can escalate privileges to the other cluster's project.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
A vulnerability has been identified within Rancher where a user with the ability to create a project, on a certain cluster, can create a project with the same name as an existing project in a different cluster. This results in the user gaining access to the other project in the different cluster, resulting in a privilege escalation. This happens because the namespace used on the local cluster to store related resources (PRTBs and secrets) is the name of the project.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.8.0 to before 2.9.9; 2.10.0 to before 2.10.5; 2.11.0 to before 2.11.1 | 2.9.9, 2.10.5, 2.11.1 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.8.0 to before 2.9.9 | 2.9.9 | Patch available | GHSA-8h6m-wv39-239m |
| — | github.com/rancher/rancher (Go) | 2.10.0 to before 2.10.5 | 2.10.5 | Patch available | GHSA-8h6m-wv39-239m |
| — | github.com/rancher/rancher (Go) | 2.11.0 to before 2.11.1 | 2.11.1 | Patch available | GHSA-8h6m-wv39-239m |
- rancher VendorSUSE Affected 2.8.0 to before 2.9.9; 2.10.0 to before 2.10.5; 2.11.0 to before 2.11.1 Fixed in 2.9.9, 2.10.5, 2.11.1 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.8.0 to before 2.9.9 Fixed in 2.9.9 Patch available GHSA-8h6m-wv39-239m
- github.com/rancher/rancher (Go) Vendor— Affected 2.10.0 to before 2.10.5 Fixed in 2.10.5 Patch available GHSA-8h6m-wv39-239m
- github.com/rancher/rancher (Go) Vendor— Affected 2.11.0 to before 2.11.1 Fixed in 2.11.1 Patch available GHSA-8h6m-wv39-239m
Remediation
Upgrade SUSE Rancher to 2.9.9, 2.10.5 or 2.11.1, depending on the release branch in use. The Go module github.com/rancher/rancher is fixed in the same versions.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA rancher (SUSE) Fixed in 2.9.9, 2.10.5, 2.11.1
- Fix · GHSA-8h6m-wv39-239m github.com/rancher/rancher (Go) Fixed in 2.9.9 Advisory →
- Fix · GHSA-8h6m-wv39-239m github.com/rancher/rancher (Go) Fixed in 2.10.5 Advisory →
- Fix · GHSA-8h6m-wv39-239m github.com/rancher/rancher (Go) Fixed in 2.11.1 Advisory →
Timeline
- 2026-10-16 Threatist record created from CVE-2024-22031
References
Other 8
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-22031
- https://github.com/rancher/rancher/security/advisories/GHSA-8h6m-wv39-239m
- https://github.com/rancher/rancher/commit/7f16b596120dd382ce6e9ed0baf83bc23f633054
- https://github.com/rancher/rancher/commit/9c1d1c2bfcba36ae4f06c1fd043eb539ad801d4d
- https://github.com/rancher/rancher/commit/b0be28f86fc556414bd9b323f05b2b4bf8317c2d
- https://github.com/rancher/rancher/commit/f036e8b6ab726c3abbc03bbf7c8d0d53373c84e5
- https://github.com/rancher/rancher
- https://pkg.go.dev/vuln/GO-2025-3647
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences