Stored cross-site scripting in LetterPress WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which is a cross-site scripting flaw (CWE-79). A high privilege user such as an admin can plant stored script that runs in other users' browsers, even when the unfiltered_html capability is disallowed, for example in a multisite setup. Exploiting it requires high privileges and user interaction, and the CVSS base score is 3.5 (low). An exploit link is listed in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LetterPress | before 2.4.0 | 2.4.0 | Patch available | CNA |
- LetterPress VendorUnknown Affected before 2.4.0 Fixed in 2.4.0 Patch available CNA
Remediation
Update LetterPress to version 2.4.0 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA LetterPress (Unknown) Fixed in 2.4.0
Timeline
- 2026-10-29 Threatist record created from CVE-2024-3586
- 2026-10-29 Alias added: GHSA-vq6v-qjj6-f2p8
- 2026-10-29 CVSS score added · CISA ADP
- 2026-10-29 Weakness changed · CISA ADP
- 2026-10-29 CISA SSVC decision points changed
References
Sources
- CVE-2024-3586 · CVE Program
- CVE-2024-3586 · NVD
- FIRST EPSS
- GHSA-vq6v-qjj6-f2p8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences