Hyland Alfresco Community Edition URL s cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability classified as problematic has been found in Hyland Alfresco Community Edition and Alfresco Enterprise Edition up to 6.2.2. This affects an unknown part of the file /share/s/ of the component URL Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-0557
- 2026-10-03 Alias added: GHSA-5m9w-g6xc-gmvc
References
—
More Hyland vulnerabilities
- TI-2025-24307 Hyland OnBase < 17.0.2.87 .NET Remoting TCP Channel Unauthenticated RCE CVSS 4.0CRITICAL 10.0
- TI-2026-41859 PACSgear MediaWriter 5.2.1 Unauthenticated RCE via .NET Remoting TCP Service CVSS 4.0CRITICAL 9.3
- TI-2026-41858 PACSgear PACS Scan 5.2.1 Unauthenticated RCE via .NET Remoting TCP Service CVSS 4.0CRITICAL 9.3
- TI-2023-27323 An issue was discovered in Hyland Alfresco Community Edition through 7.2.0. CVSS 3.1HIGH 8.8
- TI-2024-26898 A reflected cross-site scripting (XSS) vulnerability in Hyland Alfresco Platform… CVSS 3.1MEDIUM 6.1
- TI-2021-12493 Regular expression Denial of Service in MooTools CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-0557 · CVE Program
- CVE-2025-0557 · NVD
- FIRST EPSS
- GHSA-5m9w-g6xc-gmvc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences