Remote Code Execution in PlotAI
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code. Vendor commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk. The vendor does not plan to release a patch to fix this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mljar | PlotAI | up to 0.0.6 | — | No fix listed | CNA |
| — | plotai (PyPI) | before 0.0.7 | 0.0.7 | Patch available | GHSA-2hmp-5wqg-f24h |
- PlotAI Vendormljar Affected up to 0.0.6 Fixed in — No fix listed CNA
- plotai (PyPI) Vendor— Affected before 0.0.7 Fixed in 0.0.7 Patch available GHSA-2hmp-5wqg-f24h
Remediation
- Fix · GHSA-2hmp-5wqg-f24h plotai (PyPI) Fixed in 0.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1497
- 2026-10-03 Alias added: GHSA-2hmp-5wqg-f24h
References
Advisory 3
Sources
- CVE-2025-1497 · CVE Program
- CVE-2025-1497 · NVD
- FIRST EPSS
- GHSA-2hmp-5wqg-f24h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences