Ultimate Dashboard < 3.8.6 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ultimate Dashboard WordPress plugin before 3.8.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ultimate Dashboard | before 3.8.6 | 3.8.6 | Patch available | CNA |
- Ultimate Dashboard VendorUnknown Affected before 3.8.6 Fixed in 3.8.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:davidvongries:ultimate_dashboard:*:*:*:*:*:wordpress:*:* | before 3.8.6 | Vulnerable | David Vongries |
- cpe:2.3:a:davidvongries:ultimate_dashboard:*:*:*:*:*:wordpress:*:* Versions before 3.8.6 Vulnerable ·David Vongries
Remediation
- Fix · CNA Ultimate Dashboard (Unknown) Fixed in 3.8.6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Ultimate Dashboard 3.8.6
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2025-01312 Ultimate Dashboard < 3.8.6 - Admin+ Stored XSSPriority MEDIUM 50
- TI-2025-01311 Ultimate Dashboard < 3.8.6 - Admin+ Stored XSSPriority MEDIUM 50
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1523
- 2026-10-03 Alias added: GHSA-4mpp-jp65-h4rw
References
More David Vongries Ultimate Dashboard vulnerabilities
- TI-2025-01312 Ultimate Dashboard < 3.8.6 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2025-01311 Ultimate Dashboard < 3.8.6 - Admin+ Stored XSS CVSS 3.1LOW 3.5
- TI-2023-27733 WordPress Ultimate Dashboard Plugin <= 3.7.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2023-04354 Ultimate Dashboard <= 3.7.7 - Authenticated (Administrator+) Stored Cross-Site Scripting via plugin settings CVSS 3.1MEDIUM 4.8
Sources
- CVE-2025-1523 · CVE Program
- CVE-2025-1523 · NVD
- FIRST EPSS
- GHSA-4mpp-jp65-h4rw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences