MongoDB Compass may be susceptible to local privilege escalation in Windows
Priority LOW 35CWE-426Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-426.
Summary
MongoDB Compass may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privileges, when a crafted file is stored in C:\node_modules\. This issue affects MongoDB Compass prior to 1.42.1
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00147 3rd percentileScored 2026-11-07
Fix Fixed MongoDB Compass (MongoDB Inc): 1.42.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | MongoDB Compass | before 1.42.1 | 1.42.1 | Patch available | CNA |
- MongoDB Compass VendorMongoDB Affected before 1.42.1 Fixed in 1.42.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:compass:*:*:*:*:*:*:*:* | before 1.42.1 | Vulnerable | MongoDB |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:redhat:enterprise_linux_for_arm_64:9.0_aarch64:*:*:*:*:*:*:* | 9.0_aarch64 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems:9.0_s390x:*:*:*:*:*:*:* | 9.0_s390x | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions:9.0_ppc64le:*:*:*:*:*:*:* | 9.0_ppc64le | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_update_services_for_sap_solutions:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Red Hat |
- cpe:2.3:a:mongodb:compass:*:*:*:*:*:*:*:* Versions before 1.42.1 Vulnerable ·MongoDB
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:redhat:enterprise_linux_for_arm_64:9.0_aarch64:*:*:*:*:*:*:* Versions 9.0_aarch64 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems:9.0_s390x:*:*:*:*:*:*:* Versions 9.0_s390x Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions:9.0_ppc64le:*:*:*:*:*:*:* Versions 9.0_ppc64le Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_update_services_for_sap_solutions:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Red Hat
Remediation
- Fix · CNA MongoDB Compass (MongoDB Inc) Fixed in 1.42.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1755
- 2026-10-03 Alias added: GHSA-25hc-2p68-qc2g
References
More MongoDB Compass vulnerabilities
- TI-2024-05918 ejson shell parser in MongoDB Compass maybe bypassed CVSS 3.1CRITICAL 9.8
- TI-2026-12544 OS command injection in MongoDB Compass CVSS 4.0HIGH 8.4
- TI-2021-03622 Local privilege escalation in MongoDB Compass for Windows CVSS 3.1HIGH 7.8
- TI-2024-03155 Insufficient validation of external input in Compass may enable MITM attacks CVSS 3.1HIGH 7.1
- TI-2026-07998 Prototype pollution in MongoDB Compass CVSS 4.0MEDIUM 5.3
Sources
- CVE-2025-1755 · CVE Program
- CVE-2025-1755 · NVD
- FIRST EPSS
- GHSA-25hc-2p68-qc2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences