MongoDB Shell may be susceptible to local privilege escalation in Windows
Priority LOW 35CWE-426Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-426.
Summary
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00161 5th percentileScored 2026-11-07
Fix Fixed mongosh (MongoDB Inc): 2.3.0mongosh (npm): 2.3.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MongoDB | mongosh | before 2.3.0 | 2.3.0 | Patch available | CNA |
| — | mongosh (npm) | before 2.3.0 | 2.3.0 | Patch available | GHSA-f5w3-73h4-jpcm |
- mongosh VendorMongoDB Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
- mongosh (npm) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-f5w3-73h4-jpcm
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongodb:mongosh:*:*:*:*:*:*:*:* | before 2.3.0 | Vulnerable | MongoDB |
| cpe:2.3:a:redhat:codeready_linux_builder_eus:9.4:*:*:*:*:*:*:* | 9.4 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:codeready_linux_builder_for_arm64_eus:9.4_aarch64:*:*:*:*:*:*:* | 9.4_aarch64 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:codeready_linux_builder_for_ibm_z_systems_eus:9.4_s390x:*:*:*:*:*:*:* | 9.4_s390x | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:codeready_linux_builder_for_power_little_endian_eus:9.4_ppc64le:*:*:*:*:*:*:* | 9.4_ppc64le | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:enterprise_linux_update_services_for_sap_solutions:9.4:*:*:*:*:*:*:* | 9.4 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_eus:9.4:*:*:*:*:*:*:* | 9.4 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_arm_64:9.4_aarch64:*:*:*:*:*:*:* | 9.4_aarch64 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_arm_64_eus:9.4_aarch64:*:*:*:*:*:*:* | 9.4_aarch64 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems:9.4_s390x:*:*:*:*:*:*:* | 9.4_s390x | Vulnerable | Red Hat |
- cpe:2.3:a:mongodb:mongosh:*:*:*:*:*:*:*:* Versions before 2.3.0 Vulnerable ·MongoDB
- cpe:2.3:a:redhat:codeready_linux_builder_eus:9.4:*:*:*:*:*:*:* Versions 9.4 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:codeready_linux_builder_for_arm64_eus:9.4_aarch64:*:*:*:*:*:*:* Versions 9.4_aarch64 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:codeready_linux_builder_for_ibm_z_systems_eus:9.4_s390x:*:*:*:*:*:*:* Versions 9.4_s390x Vulnerable ·Red Hat
- cpe:2.3:a:redhat:codeready_linux_builder_for_power_little_endian_eus:9.4_ppc64le:*:*:*:*:*:*:* Versions 9.4_ppc64le Vulnerable ·Red Hat
- cpe:2.3:a:redhat:enterprise_linux_update_services_for_sap_solutions:9.4:*:*:*:*:*:*:* Versions 9.4 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_eus:9.4:*:*:*:*:*:*:* Versions 9.4 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_arm_64:9.4_aarch64:*:*:*:*:*:*:* Versions 9.4_aarch64 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_arm_64_eus:9.4_aarch64:*:*:*:*:*:*:* Versions 9.4_aarch64 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems:9.4_s390x:*:*:*:*:*:*:* Versions 9.4_s390x Vulnerable ·Red Hat
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems_eus:9.4_s390x:*:*:*:*:*:*:* | 9.4_s390x | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_for_power_little_endian_eus:9.4_ppc64le:*:*:*:*:*:*:* | 9.4_ppc64le | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:9.4:*:*:*:*:*:*:* | 9.4 | Vulnerable | Red Hat |
- cpe:2.3:o:redhat:enterprise_linux_for_ibm_z_systems_eus:9.4_s390x:*:*:*:*:*:*:* Versions 9.4_s390x Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_for_power_little_endian_eus:9.4_ppc64le:*:*:*:*:*:*:* Versions 9.4_ppc64le Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:9.4:*:*:*:*:*:*:* Versions 9.4 Vulnerable ·Red Hat
Remediation
- Fix · CNA mongosh (MongoDB Inc) Fixed in 2.3.0
- Fix · GHSA-f5w3-73h4-jpcm mongosh (npm) Fixed in 2.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1756
- 2026-10-03 Alias added: GHSA-f5w3-73h4-jpcm
References
More MongoDB Mongosh vulnerabilities
- TI-2025-01455 MongoDB Shell may be susceptible to control character injection via pasting CVSS 3.1HIGH 8.8
- TI-2025-01454 MongoDB Shell may be susceptible to Control Character Injection via autocomplete CVSS 3.1HIGH 7.6
- TI-2025-01456 MongoDB Shell may be susceptible to control character Injection via shell output CVSS 3.1MEDIUM 6.8
Sources
- CVE-2025-1756 · CVE Program
- CVE-2025-1756 · NVD
- FIRST EPSS
- GHSA-f5w3-73h4-jpcm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences