Cross-site scripting in portfoliohub WordPress Portfolio Builder – Portfolio Gallery
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Portfolio Builder – Portfolio Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'pfhub_portfolio' and 'pfhub_portfolio_portfolio' shortcodes in all versions up to, and including, 1.1.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| portfoliohub | WordPress Portfolio Builder – Portfolio Gallery | up to 1.1.7 | — | No fix listed | CNA |
- WordPress Portfolio Builder – Portfolio Gallery Vendorportfoliohub Affected up to 1.1.7 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:portfoliohub:portfoliohub:*:*:*:*:*:wordpress:*:* | up to 1.1.7 | Vulnerable | portfoliohub |
- cpe:2.3:a:portfoliohub:portfoliohub:*:*:*:*:*:wordpress:*:* Versions up to 1.1.7 Vulnerable ·portfoliohub
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1757
- 2026-10-03 Alias added: GHSA-9ffm-4mfx-v85f
References
More Portfoliohub vulnerabilities
- TI-2024-12276 WordPress Portfolio Builder – Portfolio Gallery <= 1.1.7 - Missing Authorization to Unauthenticated Portfolio Update CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-1757 · CVE Program
- CVE-2025-1757 · NVD
- FIRST EPSS
- GHSA-9ffm-4mfx-v85f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences