Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Priority MEDIUM 40CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An issue has been discovered in GitLab EE that allows for cross-site-scripting attack and content security policy bypass in a user's browser under specific conditions, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00566 47th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed GitLab (GitLab): 17.9.7, 17.10.5, 17.11.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.6 to before 17.9.7; 17.10 to before 17.10.5; 17.11 to before 17.11.1 | 17.9.7, 17.10.5, 17.11.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.6 to before 17.9.7; 17.10 to before 17.10.5; 17.11 to before 17.11.1 Fixed in 17.9.7, 17.10.5, 17.11.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.6.0 to before 17.9.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.6.0 to before 17.9.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.10.0 to before 17.10.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.10.0 to before 17.10.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.11.0:*:*:*:community:*:*:* | 17.11.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:17.11.0:*:*:*:enterprise:*:*:* | 17.11.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.6.0 to before 17.9.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.6.0 to before 17.9.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.10.0 to before 17.10.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.10.0 to before 17.10.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.11.0:*:*:*:community:*:*:* Versions 17.11.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:17.11.0:*:*:*:enterprise:*:*:* Versions 17.11.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 17.9.7, 17.10.5, 17.11.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1763
- 2026-10-03 Alias added: GHSA-j875-427q-5q22
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-1763 · CVE Program
- CVE-2025-1763 · NVD
- FIRST EPSS
- GHSA-j875-427q-5q22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences