LoginPress <= 3.3.1 - Cross-Site Request Forgery to Arbitrary Options Update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The LoginPress | wp-login Custom Login Page Customizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.3.1. This is due to missing or incorrect nonce validation on the 'custom_plugin_set_option' function. This makes it possible for unauthenticated attackers to update arbitrary options on the WordPress site via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site. The 'WPBRIGADE_SDK__DEV_MODE' constant must be set to 'true' to exploit the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hiddenpearls | LoginPress | wp-login Custom Login Page Customizer | up to 3.3.1 | — | No fix listed | CNA |
- LoginPress | wp-login Custom Login Page Customizer Vendorhiddenpearls Affected up to 3.3.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1764
- 2026-10-03 Alias added: GHSA-xj9h-82qf-qx5w
References
More hiddenpearls vulnerabilities
- TI-2025-01848 WP Headers And Footers <= 3.1.1 - Cross-Site Request Forgery to Arbitrary Options Update CVSS 3.1HIGH 7.5
- TI-2022-04562 Freemius SDK <= 2.4.2 - Missing Authorization Checks CVSS 3.1MEDIUM 6.3
Sources
- CVE-2025-1764 · CVE Program
- CVE-2025-1764 · NVD
- FIRST EPSS
- GHSA-xj9h-82qf-qx5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences