Missing authorization in SeaTheme BM Content Builder
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The BM Content Builder plugin for WordPress is vulnerable to unauthorized modification of data to a missing capability check on the 'ux_cb_page_options_save' function in all versions up to, and including, 3.16.2.1. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1777
- 2026-10-03 Alias added: GHSA-q9jq-f2hm-mq6f
References
More SeaTheme vulnerabilities
- TI-2025-01095 BM Content Builder < 3.17.1 - Authenticated (Subscriber+) Arbitrary File Deletion CVSS 3.1HIGH 8.8
- TI-2025-01093 BM Content Builder <= 3.16.2.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2025-36645 WordPress BM Content Builder Plugin < 3.16.3.3 - Arbitrary File Deletion Vulnerability CVSS 3.1HIGH 7.7
- TI-2025-01094 BM Content Builder < 3.17.1 - Authenticated (Subscriber+) Arbitrary File Read CVSS 3.1MEDIUM 6.5
- TI-2025-42510 WordPress BM Content Builder plugin < 3.16.3.3 - Arbitrary File Download vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-01531 Art Theme <= 3.12.2.3 - Missing Authorization to Authenticated (Subscriber+) Theme Option Delete CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-1777 · CVE Program
- CVE-2025-1777 · NVD
- FIRST EPSS
- GHSA-q9jq-f2hm-mq6f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences