Origin validation error in Genetec Update Service
Priority LOW 27CWE-346Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-346.
Summary
Local admin could to leak information from the Genetec Update Service configuration web page. An authenticated, admin privileged, Windows user could exploit this vulnerability to gain elevated privileges in the Genetec Update Service. Could be combined with CVE-2025-1789 to achieve low privilege escalation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.001 0th percentileScored 2026-11-07
Fix Fixed Genetec Update Service (Genetec Inc.): 2.10.600, >=2.10.600
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Genetec Inc. | Genetec Update Service | before 2.10.600 | 2.10.600, >=2.10.600 | Patch available | CNA |
- Genetec Update Service VendorGenetec Inc. Affected before 2.10.600 Fixed in 2.10.600, >=2.10.600 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:genetec:genetec_update_service:*:*:*:*:*:*:*:* | before 2.10.6 | Vulnerable | Genetec Inc. |
- cpe:2.3:a:genetec:genetec_update_service:*:*:*:*:*:*:*:* Versions before 2.10.6 Vulnerable ·Genetec Inc.
Remediation
- Fix · CNA Genetec Update Service (Genetec Inc.) Fixed in 2.10.600, >=2.10.600
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1787
- 2026-10-03 Alias added: GHSA-fpg9-3qpq-vpm5
References
More Genetec Inc. Genetec Update Service vulnerabilities
- TI-2025-01541 Incorrect default permissions in Genetec Update Service CVSS 4.0MEDIUM 5.8
Sources
- CVE-2025-1787 · CVE Program
- CVE-2025-1787 · NVD
- FIRST EPSS
- GHSA-fpg9-3qpq-vpm5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences