Aap-gateway: aap-gateway privilege escalation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
A flaw was found in the Ansible aap-gateway. Concurrent requests handled by the gateway grpc service can result in concurrency issues due to race condition requests against the proxy. This issue potentially allows a less privileged user to obtain the JWT of a greater privileged user, enabling the server to be jeopardized. A user session or confidential data might be vulnerable.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | automation-gateway | 2.5.0 to before 2.5.20250305-1 | 2.5.20250305-1 | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 8 | — | 2.5.20250305-1.el8ap | Patch available | CNA |
| Red Hat | Red Hat Ansible Automation Platform 2.5 for RHEL 9 | — | 2.5.20250305-1.el9ap | Patch available | CNA |
- automation-gateway Vendor— Affected 2.5.0 to before 2.5.20250305-1 Fixed in 2.5.20250305-1 Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 VendorRed Hat Affected — Fixed in 2.5.20250305-1.el8ap Patch available CNA
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 VendorRed Hat Affected — Fixed in 2.5.20250305-1.el9ap Patch available CNA
Remediation
- Fix · CNA automation-gateway Fixed in 2.5.20250305-1
Red Hat 1 advisory
- RHSA-2025:1954 Released 2025-03-01 · Red Hat rating ImportantRed Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 automation-gateway-2.5.20250305-1.el8ap, automation-gateway-config-2.5.20250305-1.el8ap, automation-gateway-server-2.5.20250305-1.el8ap
- Red Hat Ansible Automation Platform 2.5 for RHEL 9 automation-gateway-2.5.20250305-1.el9ap, automation-gateway-config-2.5.20250305-1.el9ap, automation-gateway-server-2.5.20250305-1.el9ap
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | Fixed | RHSA-2025:1954 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 9 | Fixed | RHSA-2025:1954 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1801
- 2026-10-03 Alias added: GHSA-fj43-p45h-jjgv
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-1801 · CVE Program
- CVE-2025-1801 · NVD
- FIRST EPSS
- GHSA-fj43-p45h-jjgv · GitHub Advisory Database · CC BY 4.0
- CVE-2025-1801 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences