Read the docs
TI-2025-01554 Aliases CVE-2025-1802GHSA-j46h-c723-q9rm

Cross-site scripting in devitemsllc HT Mega Addons for Elementor – Elementor Widgets &…

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘marker_title’, 'notification_content', and 'stt_button_text' parameters in all versions up to, and including, 2.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00295 22nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
devitemsllcHT Mega Addons for Elementor – Elementor Widgets & Template Builderup to 2.8.3—No fix listedCNA
  • HT Mega Addons for Elementor – Elementor Widgets & Template Builder Vendordevitemsllc Affected up to 2.8.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:hasthemes:ht_mega:*:*:*:*:free:wordpress:*:*before 2.8.4Vulnerabledevitemsllc
  • cpe:2.3:a:hasthemes:ht_mega:*:*:*:*:free:wordpress:*:* Versions before 2.8.4 Vulnerable ·devitemsllc

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-1802
  2. 2026-10-03 Alias added: GHSA-j46h-c723-q9rm

References

  • TI-2023-19431 WordPress HT Mega Absolute Addons for Elementor plugin <= 2.2.0 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-01837 HT Mega – Absolute Addons For Elementor <= 2.4.5 - Authenticated (Contributor+) Directory Traversal CVSS 3.1HIGH 8.8
  • TI-2023-05708 HT Mega – Absolute Addons For Elementor <= 2.4.6 - Sensitive Information Exposure via purchased_products CVSS 3.1HIGH 7.5
  • TI-2024-25940 WordPress HT Mega plugin <= 2.5.7 - JSON Path Traversal vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-28181 WordPress HT Mega Plugin <= 2.3.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-11691 Cross-site scripting in devitemsllc HT Mega Addons for Elementor – Elementor Widgets &… CVSS 3.1MEDIUM 6.4
See all 29 →

Sources