Import Export Suite for CSV and XML Datafeed <= 7.19 - Authenticated (Subscriber+) Arbitrary File Deletion
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Import Export Suite for CSV and XML Datafeed plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the deleteImage() function in all versions up to, and including, 7.19. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). Please note this vulnerability was reintroduced in 7.20, and subsequently patched again in 7.20.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| smackcoders | WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress | up to 7.19; 7.20 | — | No fix listed | CNA |
- WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress Vendorsmackcoders Affected up to 7.19; 7.20 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smackcoders:wp_ultimate_csv_importer:*:*:*:*:*:*:*:* | — | — | smackcoders |
- cpe:2.3:a:smackcoders:wp_ultimate_csv_importer:*:*:*:*:*:*:*:* Versions — — ·smackcoders
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2007
- 2026-10-03 Alias added: GHSA-vmmh-qx88-m8x2
References
More smackcoders vulnerabilities
- TI-2022-03538 Visual Email Designer for WooCommerce < 1.7.2 - Multiple Author+ SQLi CVSS 3.1HIGH 8.8
- TI-2022-02996 Import all XML, CSV & TXT into WordPress < 6.5.8 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2022-02997 Import all XML, CSV & TXT into WordPress < 6.5.8 - Missing Authorisation CVSS 3.1MEDIUM 4.2
- TI-2025-02048 Export All Posts, Products, Orders, Refunds & Users <= 2.13 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2024-37247 WordPress WP Ultimate Exporter plugin <= 2.9.1 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.1
- TI-2024-29554 WordPress SendGrid for WordPress plugin <= 1.4 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-2007 · CVE Program
- CVE-2025-2007 · NVD
- FIRST EPSS
- GHSA-vmmh-qx88-m8x2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences