Path traversal in MyThemeShop WordPress Review Plugin: The Ultimate Solution for Building…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The WordPress Review Plugin: The Ultimate Solution for Building a Review Website plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 5.3.5 via the Post custom fields. This makes it possible for authenticated attackers, with Contributor-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where PHP file types can be uploaded and included, or pearcmd is enabled on a server with register_argc_argv also enabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MyThemeShop | WordPress Review Plugin: The Ultimate Solution for Building a Review Website | up to 5.3.5 | — | No fix listed | CNA |
- WordPress Review Plugin: The Ultimate Solution for Building a Review Website VendorMyThemeShop Affected up to 5.3.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2158
- 2026-10-03 Alias added: GHSA-fr8x-m9pr-h4rh
References
More MyThemeShop vulnerabilities
- TI-2025-07711 My WP Translate <= 1.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2023-09695 WordPress URL Shortener by MyThemeShop Plugin <= 1.0.17 is vulnerable to Broken Access Control CVSS 3.1HIGH 8.8
- TI-2017-13742 The my-wp-translate plugin before 1.0.4 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2023-13035 WordPress WP Shortcode by MyThemeShop Plugin <= 1.4.16 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-14308 WordPress URL Shortener by MyThemeShop Plugin <= 1.0.17 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2017-13741 The my-wp-translate plugin before 1.0.4 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2025-2158 · CVE Program
- CVE-2025-2158 · NVD
- FIRST EPSS
- GHSA-fr8x-m9pr-h4rh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences