Read the docs
TI-2025-01904 Aliases CVE-2025-2172GHSA-wr65-2r27-crgw

OS command injection in Aviatrix Controller

Priority MEDIUM 64CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.

Summary

Aviatrix Controller versions prior to 7.1.4208, 7.2.5090, and 8.0.0 fail to sanitize user input prior to passing the input to command line utilities, allowing command injection via special characters in filenames

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.12223 96th percentileScored 2026-11-07
Fix Fixed Controller (Aviatrix): 7.1.4208, 7.2.5090, 8.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AviatrixController—7.1.4208, 7.2.5090, 8.0.0Patch availableCNA
  • Controller VendorAviatrix Affected — Fixed in 7.1.4208, 7.2.5090, 8.0.0 Patch available CNA

Remediation

  • Fix · CNA Controller (Aviatrix) Fixed in 7.1.4208, 7.2.5090, 8.0.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-2172
  2. 2026-10-03 Alias added: GHSA-wr65-2r27-crgw

References

  • TI-2024-34029 OS command injection in Aviatrix Controller KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-17791 An issue was discovered in Aviatrix Controller 6.x before 6.5-1804.1922. KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-01903 Missing brute-force protection in Aviatrix Controller CVSS 4.0HIGH 7.8
  • TI-2020-16187 An issue was discovered in Aviatrix Controller before R6.0.2483. CVSS 3.1CRITICAL 9.8
  • TI-2020-10521 An Elevation of Privilege issue was discovered in Aviatrix VPN Client before 2.10.7… CVSS 3.1CRITICAL 9.8
  • TI-2020-05833 The Aviatrix OpenVPN client through 2.5.7 on Linux, macOS, and Windows is vulnerable when… CVSS 3.1CRITICAL 9.8
See all 22 →

Sources