WooCommerce Checkout & Funnel Builder by FunnelKit < 3.10.2 - Admin+ SQL Injection
Priority HIGH 68CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The FunnelKit WordPress plugin before 3.10.2 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00271 19th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed FunnelKit (Unknown): 3.10.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | FunnelKit | before 3.10.2 | 3.10.2 | Patch available | CNA |
- FunnelKit VendorUnknown Affected before 3.10.2 Fixed in 3.10.2 Patch available CNA
Remediation
- Fix · CNA FunnelKit (Unknown) Fixed in 3.10.2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2203
- 2026-10-03 Alias added: GHSA-8xj4-6h2f-28vg
References
More FunnelKit Funnel Builder vulnerabilities
- TI-2023-27761 WordPress Funnel Builder for WordPress by FunnelKit Plugin <= 2.14.3 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2024-04818 Cross-site scripting in FunnelKit – Funnel Builder for WooCommerce Checkout CVSS 3.1MEDIUM 6.4
- TI-2024-00977 Cross-site scripting in FunnelKit Funnel Builder Pro CVSS 3.1MEDIUM 6.4
- TI-2024-06339 Missing authorization in FunnelKit – Funnel Builder for WooCommerce Checkout CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-2203 · CVE Program
- CVE-2025-2203 · NVD
- FIRST EPSS
- GHSA-8xj4-6h2f-28vg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences