Cross-site scripting in CyberChimps Responsive Addons for Elementor – Free Elementor…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘rael_title_tag' parameter in all versions up to, and including, 1.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 1.6.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CyberChimps | Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates | up to 1.6.9 | — | No fix listed | CNA |
- Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates VendorCyberChimps Affected up to 1.6.9 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cyberchimps:responsive_addons_for_elementor:*:*:*:*:*:wordpress:*:* | before 1.6.9.1 | Vulnerable | CyberChimps |
- cpe:2.3:a:cyberchimps:responsive_addons_for_elementor:*:*:*:*:*:wordpress:*:* Versions before 1.6.9.1 Vulnerable ·CyberChimps
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2225
- 2026-10-03 Alias added: GHSA-6975-j4h6-fxff
References
More CyberChimps Responsive Addons For Elementor vulnerabilities
- TI-2024-12395 Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates <=… CVSS 3.1HIGH 8.8
- TI-2024-35030 WordPress Responsive Addons for Elementor plugin <= 1.5.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-33895 WordPress Responsive Addons for Elementor plugin <= 1.7.3 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-01955 Information disclosure in CyberChimps Responsive Addons for Elementor – Free Elementor… CVSS 3.1MEDIUM 5.7
Sources
- CVE-2025-2225 · CVE Program
- CVE-2025-2225 · NVD
- FIRST EPSS
- GHSA-6975-j4h6-fxff · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences