Read the docs
TI-2025-02011 Aliases CVE-2025-2291GHSA-qj9w-64mv-p2fw

PgBouncer default auth_query does not take Postgres password expiry into account

Priority MEDIUM 43CWE-324Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

Password can be used past expiry in PgBouncer due to auth_query not taking into account Postgres its VALID UNTIL value, which allows an attacker to log in with an already expired password

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00368 30th percentileScored 2026-11-07
Fix Fixed PgBouncer: 1.24.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—PgBouncerbefore 1.24.11.24.1Patch availableCNA
  • PgBouncer Vendor— Affected before 1.24.1 Fixed in 1.24.1 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:pgbouncer:pgbouncer:*:*:*:*:*:*:*:*before 1.24.1VulnerablePgbouncer
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*11.0VulnerableDebian
  • cpe:2.3:a:pgbouncer:pgbouncer:*:*:*:*:*:*:*:* Versions before 1.24.1 Vulnerable ·Pgbouncer
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian

Remediation

  • Fix · CNA PgBouncer Fixed in 1.24.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-2291
  2. 2026-10-03 Alias added: GHSA-qj9w-64mv-p2fw

References

Sources