User Registration & Membership < 4.1.3 - Authentication Bypass
Priority HIGH 70Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The User Registration & Membership WordPress plugin before 4.1.3 does not properly validate data in an AJAX action when the Membership Addon is enabled, allowing attackers to authenticate as any user, including administrators, by simply using the target account's user ID.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.09524 95th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed User Registration & Membership (Unknown): 4.1.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | User Registration & Membership | before 4.1.3 | 4.1.3 | Patch available | CNA |
- User Registration & Membership VendorUnknown Affected before 4.1.3 Fixed in 4.1.3 Patch available CNA
Remediation
- Fix · CNA User Registration & Membership (Unknown) Fixed in 4.1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2594
- 2026-10-03 Alias added: GHSA-hmpr-r93w-5j44
References
More wpeverest User Registration & Membership vulnerabilities
- TI-2025-02232 User Registration & Membership < 4.1.2- Unauthenticated Privilege Escalation CVSS 3.1HIGH 8.1
- TI-2023-12191 WordPress User Registration plugin <= 2.3.2.1 - Authenticated PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-26142 WordPress User Registration plugin < 4.2.0 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-02874 Authorization bypass in wpeverest User Registration & Membership – Free & Paid… CVSS 3.1MEDIUM 5.3
- TI-2024-01599 Cross-site scripting in wpeverest User Registration & Membership – Free & Paid… CVSS 3.1MEDIUM 6.1
- TI-2025-22169 WordPress User Registration plugin <= 4.0.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2025-2594 · CVE Program
- CVE-2025-2594 · NVD
- FIRST EPSS
- GHSA-hmpr-r93w-5j44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences