PDF signature forgery with adbe.pkcs7.sha1 SubFilter
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-347.
Summary
Improper Verification of Cryptographic Signature vulnerability in LibreOffice allows PDF Signature Spoofing by Improper Validation. In the affected versions of LibreOffice a flaw in the verification code for adbe.pkcs7.sha1 signatures could cause invalid signatures to be accepted as valid This issue affects LibreOffice: from 24.8 before < 24.8.6, from 25.2 before < 25.2.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| The Document Foundation | LibreOffice | 24.8 to before < 24.8.6; 25.2 to before < 25.2.2 | < 24.8.6, < 25.2.2 | Patch available | CNA |
- LibreOffice VendorThe Document Foundation Affected 24.8 to before < 24.8.6; 25.2 to before < 25.2.2 Fixed in < 24.8.6, < 25.2.2 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* | 24.8.0.1 to before 24.8.6.0; 25.2.0.1 to before 25.2.2 | Vulnerable | The Document Foundation |
| cpe:2.3:a:libreoffice:libreoffice:24.8.0.0:alpha1:*:*:*:*:*:* | 24.8.0.0 alpha1 | Vulnerable | The Document Foundation |
| cpe:2.3:a:libreoffice:libreoffice:24.8.0.0:beta1:*:*:*:*:*:* | 24.8.0.0 beta1 | Vulnerable | The Document Foundation |
| cpe:2.3:a:libreoffice:libreoffice:25.2.0.0:alpha1:*:*:*:*:*:* | 25.2.0.0 alpha1 | Vulnerable | The Document Foundation |
| cpe:2.3:a:libreoffice:libreoffice:25.2.0.0:beta1:*:*:*:*:*:* | 25.2.0.0 beta1 | Vulnerable | The Document Foundation |
- cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* Versions 24.8.0.1 to before 24.8.6.0; 25.2.0.1 to before 25.2.2 Vulnerable ·The Document Foundation
- cpe:2.3:a:libreoffice:libreoffice:24.8.0.0:alpha1:*:*:*:*:*:* Versions 24.8.0.0 alpha1 Vulnerable ·The Document Foundation
- cpe:2.3:a:libreoffice:libreoffice:24.8.0.0:beta1:*:*:*:*:*:* Versions 24.8.0.0 beta1 Vulnerable ·The Document Foundation
- cpe:2.3:a:libreoffice:libreoffice:25.2.0.0:alpha1:*:*:*:*:*:* Versions 25.2.0.0 alpha1 Vulnerable ·The Document Foundation
- cpe:2.3:a:libreoffice:libreoffice:25.2.0.0:beta1:*:*:*:*:*:* Versions 25.2.0.0 beta1 Vulnerable ·The Document Foundation
Remediation
- Fix · CNA LibreOffice (The Document Foundation) Fixed in < 24.8.6, < 25.2.2
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2866
- 2026-10-03 Alias added: GHSA-22mj-r7hq-f9h2
References
More The Document Foundation Libreoffice vulnerabilities
- TI-2019-07233 LibreLogo global-event script execution CVSS 3.1CRITICAL 9.8
- TI-2018-12068 Path traversal in [UNKNOWN] libreoffice CVSS 3.0CRITICAL 9.8
- TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
- TI-2019-07230 Code injection in Document Foundation LibreOffice CVSS 3.1CRITICAL 9.8
- TI-2018-05018 LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary… CVSS 3.0CRITICAL 9.8
- TI-2023-01118 Arbitrary file write in libreoffice CVSS 3.1MEDIUM 5.5
Sources
- CVE-2025-2866 · CVE Program
- CVE-2025-2866 · NVD
- FIRST EPSS
- GHSA-22mj-r7hq-f9h2 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-2866 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences