Kentico CMS Additional Database Installation Wizard install.aspx cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability was found in Kentico CMS up to 13.0.178. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /CMSInstall/install.aspx of the component Additional Database Installation Wizard. The manipulation of the argument new database leads to cross site scripting. The attack can be launched remotely. Upgrading to version 13.0.179 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2878
- 2026-10-03 Alias added: GHSA-7x38-336c-qcwr
References
More Kentico vulnerabilities
- TI-2025-02400 Kentico Xperience <= 13.0.178 Staging Sync Server None Password Type Authentication Bypass KEVCVSS 3.1CRITICAL 9.8
- TI-2025-02399 Kentico Xperience <= 13.0.172 Staging Sync Server Digest Password Authentication Bypass KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07394 An issue was discovered in Kentico 12.0.x before 12.0.15, 11.0.x before 11.0.48, 10.0.x… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-02402 Kentico Xperience <= 13.0.178 Staging Media File Upload Authenticated RCE KEVCVSS 3.1HIGH 7.2
- TI-2025-23449 Unrestricted file upload in Kentico Xperience CVSS 3.1CRITICAL 9.8
- TI-2017-12981 Kentico 9.0 before 9.0.51 and 10.0 before 10.0.48 allows remote attackers to obtain… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-2878 · CVE Program
- CVE-2025-2878 · NVD
- FIRST EPSS
- GHSA-7x38-336c-qcwr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences