An XML External Entity (XXE) vulnerability in Multiple WSO2 Products
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Due to the improper configuration of XML parser, user-supplied XML is parsed without applying sufficient restrictions, enabling XML External Entity (XXE) resolution in multiple WSO2 Products. A successful XXE attack could allow a remote, unauthenticated attacker to: * Read sensitive files from the server’s filesystem. * Perform denial-of-service (DoS) attacks, which can render the affected service unavailable.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | before 2.0.0; 2.1.0; 2.2.0; 2.5.0; 2.6.0; 3.0.0; 3.1.0; 4.0.0 to before 4.0.0.311; 4.1.0 to before 4.1.0.152; 4.2.0 to before 4.2.0.122 | 2.0.0, 4.0.0.311, 4.1.0.152, 4.2.0.122 | Patch available | CNA |
| WSO2 | WSO2 Enterprise Integrator | 6.0.0; 6.1.0; 6.1.1; 6.2.0; 6.3.0; 6.4.0; 6.5.0; 6.6.0 | — | No fix listed | CNA |
| WSO2 | WSO2 Enterprise Service Bus | 4.9.0; 5.0.0 | — | No fix listed | CNA |
| WSO2 | WSO2 Micro integrator | 1.0.0; 1.1.0; 1.2.0 to before 1.2.0.162; 4.0.0 to before 4.0.0.132; 4.1.0 to before 4.1.0.115; 4.2.0 to before 4.2.0.112 | 1.2.0.162, 4.0.0.132, 4.1.0.115, 4.2.0.112 | Patch available | CNA |
| WSO2 | WSO2 Open Banking AM | 1.5.0 | — | No fix listed | CNA |
| — | org.wso2.am:am-distribution-parent (Maven) | before 2.1.0 | 2.1.0 | Patch available | GHSA-h94w-8qhg-3xmc |
- WSO2 API Manager VendorWSO2 Affected before 2.0.0; 2.1.0; 2.2.0; 2.5.0; 2.6.0; 3.0.0; 3.1.0; 4.0.0 to before 4.0.0.311; 4.1.0 to before 4.1.0.152; 4.2.0 to before 4.2.0.122 Fixed in 2.0.0, 4.0.0.311, 4.1.0.152, 4.2.0.122 Patch available CNA
- WSO2 Enterprise Integrator VendorWSO2 Affected 6.0.0; 6.1.0; 6.1.1; 6.2.0; 6.3.0; 6.4.0; 6.5.0; 6.6.0 Fixed in — No fix listed CNA
- WSO2 Enterprise Service Bus VendorWSO2 Affected 4.9.0; 5.0.0 Fixed in — No fix listed CNA
- WSO2 Micro integrator VendorWSO2 Affected 1.0.0; 1.1.0; 1.2.0 to before 1.2.0.162; 4.0.0 to before 4.0.0.132; 4.1.0 to before 4.1.0.115; 4.2.0 to before 4.2.0.112 Fixed in 1.2.0.162, 4.0.0.132, 4.1.0.115, 4.2.0.112 Patch available CNA
- WSO2 Open Banking AM VendorWSO2 Affected 1.5.0 Fixed in — No fix listed CNA
- org.wso2.am:am-distribution-parent (Maven) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-h94w-8qhg-3xmc
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 2.0.0, 4.0.0.311, 4.1.0.152, 4.2.0.122
- Fix · CNA WSO2 Micro integrator (WSO2) Fixed in 1.2.0.162, 4.0.0.132, 4.1.0.115, 4.2.0.112
- Fix · GHSA-h94w-8qhg-3xmc org.wso2.am:am-distribution-parent (Maven) Fixed in 2.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2905
- 2026-10-03 Alias added: GHSA-h94w-8qhg-3xmc
References
Advisory 2
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2025-2905 · CVE Program
- CVE-2025-2905 · NVD
- FIRST EPSS
- GHSA-h94w-8qhg-3xmc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences