PyTorch torch.jit.script memory corruption
Priority LOW 21CWE-119Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
A vulnerability classified as critical has been found in PyTorch 2.6.0. This affects the function torch.jit.script. The manipulation leads to memory corruption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00203 10th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed torch (PyPI): 2.13.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PyTorch | 2.6.0 | — | No fix listed | CNA |
| — | torch (PyPI) | before 2.13.0 | 2.13.0 | Patch available | GHSA-rrmf-rvhw-rf47 |
- PyTorch Vendor— Affected 2.6.0 Fixed in — No fix listed CNA
- torch (PyPI) Vendor— Affected before 2.13.0 Fixed in 2.13.0 Patch available GHSA-rrmf-rvhw-rf47
Remediation
- Fix · GHSA-rrmf-rvhw-rf47 torch (PyPI) Fixed in 2.13.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3000
- 2026-10-03 Alias added: GHSA-rrmf-rvhw-rf47
References
Advisory 2
More backstage Pytorch vulnerabilities
- TI-2024-32257 In PyTorch <=2.4.1, the RemoteModule has Deserialization RCE. CVSS 3.1CRITICAL 9.8
- TI-2025-35037 A Name Error occurs in pytorch v2.7.0 when a PyTorch model consists of torch.cummin and… CVSS 3.1HIGH 7.5
- TI-2025-35034 A syntax error in the component proxy_tensor.py of pytorch v2.7.0 allows attackers to cause a Denial of Service (DoS). CVSS 3.1HIGH 7.5
- TI-2025-35033 pytorch v2.8.0 was discovered to display unexpected behavior when the components… CVSS 3.1HIGH 7.5
- TI-2025-35032 An issue in the component torch.linalg.lu of pytorch v2.8.0 allows attackers to cause a… CVSS 3.1HIGH 7.5
- TI-2025-35038 A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-3000 · CVE Program
- CVE-2025-3000 · NVD
- FIRST EPSS
- GHSA-rrmf-rvhw-rf47 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences