PyTorch torch.lstm_cell memory corruption
Priority MEDIUM 55CWE-119Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
A vulnerability classified as critical was found in PyTorch 2.6.0. This vulnerability affects the function torch.lstm_cell. The manipulation leads to memory corruption. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00202 10th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed torch (PyPI): 2.10.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PyTorch | 2.6.0 | — | No fix listed | CNA |
| — | torch (PyPI) | before 2.10.0 | 2.10.0 | Patch available | GHSA-qfhq-4f3w-5fph |
- PyTorch Vendor— Affected 2.6.0 Fixed in — No fix listed CNA
- torch (PyPI) Vendor— Affected before 2.10.0 Fixed in 2.10.0 Patch available GHSA-qfhq-4f3w-5fph
Remediation
- Fix · GHSA-qfhq-4f3w-5fph torch (PyPI) Fixed in 2.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3001
- 2026-10-03 Alias added: GHSA-qfhq-4f3w-5fph
References
Advisory 2
More backstage Pytorch vulnerabilities
- TI-2024-32257 In PyTorch <=2.4.1, the RemoteModule has Deserialization RCE. CVSS 3.1CRITICAL 9.8
- TI-2025-35037 A Name Error occurs in pytorch v2.7.0 when a PyTorch model consists of torch.cummin and… CVSS 3.1HIGH 7.5
- TI-2025-35034 A syntax error in the component proxy_tensor.py of pytorch v2.7.0 allows attackers to cause a Denial of Service (DoS). CVSS 3.1HIGH 7.5
- TI-2025-35033 pytorch v2.8.0 was discovered to display unexpected behavior when the components… CVSS 3.1HIGH 7.5
- TI-2025-35032 An issue in the component torch.linalg.lu of pytorch v2.8.0 allows attackers to cause a… CVSS 3.1HIGH 7.5
- TI-2025-35038 A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-3001 · CVE Program
- CVE-2025-3001 · NVD
- FIRST EPSS
- GHSA-qfhq-4f3w-5fph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences